GRE tunnel on Cumulus VX and ifreload

  • 1
  • Question
  • Updated 5 months ago
When creating gre tunnel in VX (v 3.3.1, v 3.3.2), I would like to put configuration in /etc/network/interfaces file, so it persists over reboot. But when bringing up interface (ifup tun0), I get an error, that it's not able to set speed on gre tunnel, and fails.

"error: tun0: cmd 'ethtool -s tun0 speed 1000 duplex full autoneg off' failed: returned 255 (Cannot get current device settings: Operation not supported

As a workaround, I managed to put config strings in /etc/rc.local - but this looks pretty ugly from networking point of view.

Also, I have tried to put the same gre config in /etc/network/interfaces on hardware switch, running Cumulus 3.3.2 - it worked, no complains.

 Could anybody, please, advise - whether it is different code on hardware and software platforms? And whether it is possible to fix behavior on virtual platform?

 Thank you.
Photo of Sergei Hanus

Sergei Hanus

  • 406 Points 250 badge 2x thumb

Posted 5 months ago

  • 1
Photo of Jason Guy

Jason Guy, Employee

  • 1,562 Points 1k badge 2x thumb
Hi Sergei, VX in more recent versions does try to emulate the ASIC being present, even though it is essentially a passthrough. However the ifupdown2 package which parses the configuration should be the same. It could be related to something with the way switchd, ethtool, or portwd works on VX. We technically do not support GRE, but in VX there is no reason this should not work. I will try it out and ask the developers what may be going on.