Keyboard input not responding

  • 1
  • Question
  • Updated 2 years ago

hi,

I am new to Cumulus VX. Downloaded the latest Cumulus VX for KVM and trying to set up a VM on a remote machine. I used TightVNC for setting up the virtual machine .

My VM boots and gives the prompt for cumulus login: .

But it does not take any keyboard entry.

Other VMs I have created on the same machines using regular Ubuntu is able to take keyboard input at the same time.

Is there anything I have missed during the setup?

 Thanks,

Amruta

Photo of Amruta Misra

Amruta Misra

  • 140 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Scott Suehle

Scott Suehle, Alum

  • 3,772 Points 3k badge 2x thumb
Amruta,

Can you share the command you used to set up the virtual machine? It should not require anything different from other VMs you have setup in the past.
Photo of Amruta Misra

Amruta Misra

  • 140 Points 100 badge 2x thumb

Hi Scott, I am not using any command. I am setting up the VM using ui from TightVNC.

btw, when I use the command mentioned in this link, I am able to run the VMs successfully and no issue with keyboard input.

https://docs.cumulusnetworks.com/display/VX/Using+Cumulus+VX+with+KVM

I am facing issue only when I set up the VM using the VNC.

thanks,

Amruta

Photo of Donald Sharp

Donald Sharp, Employee

  • 182 Points 100 badge 2x thumb
VNC is a protocol for allowing remote communication with a desktop setup on a remote server.  VNC just presents what ever graphical UI you are running on the server you are connecting too.  VNC doesn't have any ability to configure vm's, you are using some other program
Photo of Scott Suehle

Scott Suehle, Alum

  • 3,772 Points 3k badge 2x thumb
After seeing this, I would say it is a configuration issue in TightVNC. I am not familiar with that version but I would start in the settings there.