LLDP-MED Configuration

  • 1
  • Question
  • Updated 1 year ago

I need some help with LLDP-MED configuration in Cumulus, some examples would be perfect.

I got a Cisco IP-PHONE 7941G that seems to be loading up with the default "TIA - Network Policy" as,

Tagged: No

VLAN ID: 0

Which finally changes to,

Tagged: No

vlan Id 4095

Then the IPHONE gets a IP on the data vlan (untagged vlan) instead of the voice (tagged)....

So, I did some captures I don't see any "TIA - Network Policy" been advertise from the Edgecore switch on the LLDP_MULTICAST address to help out the IP-Phone get the right policy, and set tagged: yes, vlan id: X, Therefore I am assuming I need to configure it.

I have seen examples for Juniper network, but nothing on Cumulus!

Any help would be greatly appreciated.


  



Photo of Windesson Almeida

Windesson Almeida

  • 342 Points 250 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Eric Pulvino

Eric Pulvino, Official Rep

  • 4,082 Points 4k badge 2x thumb
These settings exist within the manpage for lldpcli. Search for "network policy". The /etc/lldp.d/README.conf is the file where the changes can be made persistently. I have not configured these settings before but something like this will get you close.

<code>
sudo su
echo "configure med policy application voice tagged vlan 4094" >> /etc/lldp.d/README.conf
systemctl restart lldpd
</code>

Hope that helps!
Photo of Windesson Almeida

Windesson Almeida

  • 342 Points 250 badge 2x thumb

I had it almost right..

I missed the keyword "tagged".

This seems to work, the Phone got an IP on the right VLAN (tagged), I will try to connect a PC behind it and see if it gets an IP on the  DATA VLAN(untagged).

(Edited)