MLAG setup with LACP configured host machine connect

  • 1
  • Question
  • Updated 1 year ago
  • (Edited)
Hello,

I am trying to config two switch with LACP configured  host machine connected

with reference to sample setup
https://docs.cumulusnetworks.com/display/DOCS/Multi-Chassis+Link+Aggregation+-+MLAG

where host1 is direct connected to host machine

MLAG is successful setup but however I found the bond host1 was keep done.  Where which I wrong configured?

Thanks!

------------------- config --------------------
auto peerlink
iface peerlink
        bond-slaves swp1 swp2

auto peerlink.4094
iface peerlink.4094
        address 169.254.255.1/24
        clagd-priority 4096
        clagd-peer-ip 169.254.255.2
        clagd-sys-mac 44:38:39:ff:00:01


auto host1
iface host1
        bond-slaves swp3
        clag-id 2
        mstpctl-portadminedge yes
        mstpctl-bpduguard yes


auto br0
iface br0
        bridge-vlan-aware yes
        bridge-ports host1 peerlink
        bridge-stp on
        bridge-vids 10-15
        bridge-pvid 1
        bridge-allow-untagged yes

auto br0.1
iface br0.1
        address 192.168.0.254/24
        address 192.168.2.254/24
        address-virtual 00:00:5e:00:01:01 192.168.0.1/24


auto br0.10
iface br0.10
        address 192.168.10.254/24
        address 192.168.11.254/24
        address-virtual 00:00:5e:00:01:02 192.168.10.1/24


--------------- status check -------------------------------

# netshow interface

    Name           Speed    MTU    Mode           Summary
--  -------------  -------  -----  -------------  ----------------------------------------
UP  lo             N/A      65536  Loopback       IP: 127.0.0.1/8, ::1/128
UP  eth0           1G       1500   Mgmt           IP: 192.168.1.152/24
UP  swp1           1G       1500   BondMember     Master: peerlink(UP)
UP  swp2           1G       1500   BondMember     Master: peerlink(UP)
UP  swp3           1G       1500   BondMember     Master: host1(DN)
UP  br0            N/A      1500   Bridge/L2      Untagged Members: host1, peerlink
                                                  802.1q Tag: Untagged
                                                  STP: RootSwitch(32768)
                                                  Vlan Aware Bridge
UP  br0.1          N/A      1500   SVI/L3         IP: 192.168.0.254/24, 192.168.2.254/24
UP  br0.10         N/A      1500   SVI/L3         IP: 192.168.10.254/24, 192.168.11.254/24
DN  host1          N/A      1500   Bond/Trunk     Bond Members: swp3(UN)            <-----------
                                                  Untagged VLAN: 1
                                                  VLANS: 10-15
UP  mgmt           N/A      65536  Interface/L3   IP: 172.0.0.1/8
UP  peerlink       2G       1500   Bond/Trunk     Bond Members: swp1(UP), swp2(UP)
                                                  Untagged VLAN: 1
                                                  VLANS: 10-15
UP  peerlink.4094  2G       1500   SubInt/L3      IP: 169.254.255.1/24


# sudo clagctl
The peer is alive
     Our Priority, ID, and Role: 4096 08:00:27:ec:82:56 primary
    Peer Priority, ID, and Role: 8192 08:00:27:18:3b:3c secondary
          Peer Interface and IP: peerlink.4094 169.254.255.2
                      Backup IP:  (inactive)
                     System MAC: 44:38:39:ff:00:01

CLAG Interfaces
Our Interface      Peer Interface     CLAG Id   Conflicts              Proto-Down Reason
----------------   ----------------   -------   --------------------   -----------------
           host1   -                  2         -                      -

===============================================
Thanks!
Photo of machiasiaweb

machiasiaweb

  • 930 Points 500 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Scott Suehle

Scott Suehle, Alum

  • 3,772 Points 3k badge 2x thumb
Have you looked in /var/log/clagd.log to see what it says about the host1 link? The configuration looks correct.
Photo of machiasiaweb

machiasiaweb

  • 930 Points 500 badge 2x thumb
It can find some log when I process restart network services at host1

------
2016-12-05T02:26:19.460207+00:00 cumulus clagd[954]: Cleanup is executing.
2016-12-05T02:26:19.905427+00:00 cumulus clagd[954]: Cleanup is finished
2016-12-05T02:26:20.131631+00:00 cumulus clagd[954]: Beginning execution of clagd version 1.3.0
2016-12-05T02:26:20.132221+00:00 cumulus clagd[954]: Invoked with: /usr/sbin/clagd --daemon 169.254.255.2 peerlink.4094 44:38:39:ff:00:01 --priority 4096
2016-12-05T02:26:20.203755+00:00 cumulus clagd[954]: Backup IP has not been configured
2016-12-05T02:26:20.214307+00:00 cumulus clagd[954]: Role is now secondary
2016-12-05T02:26:20.536378+00:00 cumulus clagd[954]: Initial config loaded
2016-12-05T02:27:47.280165+00:00 cumulus clagd[954]: The peer switch is active.
2016-12-05T02:27:47.293940+00:00 cumulus clagd[954]: Role is now primary; elected
2016-12-05T02:27:48.870071+00:00 cumulus clagd[954]: Initial data sync to peer done.
2016-12-05T02:27:49.318791+00:00 cumulus clagd[954]: Initial data sync from peer done.
2016-12-05T02:27:49.319053+00:00 cumulus clagd[954]: Initial handshake done.

-------  network service restart at host1 ----------------

2016-12-05T03:53:14.552890+00:00 cumulus clagd[954]: Conflict (host1): LACP partner MAC mismatch
2016-12-05T03:53:16.506180+00:00 cumulus clagd[954]: host1 is now dual connected.
2016-12-05T03:53:16.506451+00:00 cumulus clagd[954]: Conflict cleared (host1): LACP partner MAC is no longer mismatched
2016-12-05T03:54:46.802009+00:00 cumulus clagd[954]: host1 is no longer dual connected.

------------------------------------------------------------


Additional I running it under Cumulus VX with GNS3.  Does there are any limitation?

Thanks!
(Edited)
Photo of machiasiaweb

machiasiaweb

  • 930 Points 500 badge 2x thumb
I find why because it must require to setup port speed and duplex

-----
auto swp3
iface swp3
        link-speed 1000
        link-duplex full
------

may be that must include it under simulate environment.