netshow lldp broken in 2.5.7?

  • 1
  • Problem
  • Updated 2 years ago
seems Netshow lldp output is broken in 2.5.7 after you do a dist-upgrade.

Vanilla 2.5.7 loaded from ONIE netshow lldp output produces expected details, however after doing apt-get update and apt-get dist-upgrade, you get this back from "netshow lldp":

user@switch:~$ netshow lldp--------------------------------------------------------------------
To view the legend,  rerun "netshow" cmd with the  "--legend" option
--------------------------------------------------------------------
Local Port    Speed    Mode        Remote Port    Remote  Host    Summary
------------  -------  ------  --  -------------  --------------  ---------

an empty table.

lldpcli command still shows everything, however.

anyone else seen this?
Photo of Will McLendon

Will McLendon

  • 440 Points 250 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Will McLendon

Will McLendon

  • 440 Points 250 badge 2x thumb
forgot to add -- haven't noticed anything else broken inside netshow command outputs, except this one command
Photo of Scott Suehle

Scott Suehle, Alum

  • 3,772 Points 3k badge 2x thumb
Will,

Are you doing this in Cumulus VX or Cumulus Linux? I just did this in VX and was unable to replicate the issue.
Photo of Will McLendon

Will McLendon

  • 440 Points 250 badge 2x thumb
this is on real switch running Cumulus.  Dell 10G swtich, can't recall the model number.  in lab on vanilla 2.5.7 install I had lldp neighbor output running the command; dist-upgrade and reboot, no LLDP info in output.  not a crushing issue, but something I found odd
Photo of Scott Suehle

Scott Suehle, Alum

  • 3,772 Points 3k badge 2x thumb
This is odd. Couple of questions: 1. What is the version of LLDP on the switch that is not playing nicely? 2. Is there anything installed on the switch that could be interfering with the output?
Photo of Will McLendon

Will McLendon

  • 440 Points 250 badge 2x thumb
it looks like it is Version: lldpd 2016-03-07

LLDP itself is running fine so far as I can tell -- the command " sudo lldpcli show neighbors" reports neighbors as expected; neighboring switch sees the Cumulus switch in its neighbor table, etc.  Issue seems to be more specific to netshow lldp command -- it just doesn't return any data.  tried with --json option as well, and it returns '{}' -- blank values


as to number 2, nothing installed on the switch -- loaded 2.5.7 cumulus via ONIE, configured interfaces and quagga, thats it.  after the dist-upgrade, this one particular netshow command doesn't appear to work.  version details of netshow:

Netshow Version:
netshow-core: 1.1.3
netshow-cumulus: 1.1.6
netshow-linux: 1.1.6

Thanks,

Will
Photo of Eric Pulvino

Eric Pulvino, Official Rep

  • 4,082 Points 4k badge 2x thumb
2.5.7VX seems to work as expected...

root@leaf1:/home/vagrant# cat /etc/lsb-release
DISTRIB_ID="Cumulus Linux"
DISTRIB_RELEASE=2.5.7
DISTRIB_DESCRIPTION=2.5.7-753304d-201603071654-build
root@leaf1:/home/vagrant# lldpctl swp1
-------------------------------------------------------------------------------
LLDP neighbors:
-------------------------------------------------------------------------------
Interface: swp1, via: LLDP, RID: 1, Time: 0 day, 00:02:55
Chassis:
ChassisID: mac 08:00:27:8a:39:05
SysName: leaf2
SysDescr: Cumulus Linux version 2.5.6 running on innotek GmbH VirtualBox
MgmtIP: 10.0.2.15
Capability: Bridge, off
Capability: Router, on
Port:
PortID: ifname swp1
PortDescr: swp1
-------------------------------------------------------------------------------
root@leaf1:/home/vagrant# netshow lldp
--------------------------------------------------------------------
To view the legend, rerun "netshow" cmd with the "--legend" option
--------------------------------------------------------------------
Local Port Speed Mode Remote Port Remote Host Summary
------------ ------- -------------- ---- ------------- -------------- ---------
swp1 10G IntTypeUnknown ==== swp1 leaf2
swp2 10G IntTypeUnknown ==== swp2 leaf2
Photo of Gabriel Stoicea

Gabriel Stoicea

  • 120 Points 100 badge 2x thumb
Hi,

I just checked on my cumulus switches: Edge-Core AS6701-32X-C  and AS5712-54X-B, and netshow lldp it's working fine. Cumulus Linux, on both switches, have been upgraded from 2.5.6 to 2.5.7 using apt-get.
Below is the output for AS6701:

cumulus@cumulus-atlas-sw1$ cat /etc/lsb-release
DISTRIB_ID="Cumulus Linux"
DISTRIB_RELEASE=2.5.7
DISTRIB_DESCRIPTION=2.5.7-753304d-201603071654-
cumulus@cumulus-atlas-sw1$ netshow lldp
--------------------------------------------------------------------
To view the legend,  rerun "netshow" cmd with the  "--legend" option
--------------------------------------------------------------------
Local Port    Speed       Mode              Remote Port        Remote  Host                Summary
------------  ----------  ----------  ----  -----------------  --------------------------  -----------------------
eth0          1G          Mgmt        ====  gi3/0/3                                        IP: 192.168.8.73/22
swp1          40G(QSFP+)  BondMember  ====  swp1               cumulus-atlas-sw2.nipne.ro  Master: peerlink(UP)
swp13         40G(QSFP+)  BondMember  ====  fortyGigE 1/45                                 Master: mxl1link(UP)
swp14         40G(QSFP+)  BondMember  ====  fortyGigE 1/41                                 Master: mxl1link(UP)
swp15         40G(QSFP+)  BondMember  ====  fortyGigE 0/45                                 Master: mxl1link(UP)
swp16         40G(QSFP+)  BondMember  ====  fortyGigE 0/41                                 Master: mxl1link(UP)
swp17         40G(QSFP+)  BondMember  ====  fortyGigE 1/53                                 Master: mxl2link(UP)
swp18         40G(QSFP+)  BondMember  ====  fortyGigE 1/49                                 Master: mxl2link(UP)
swp19         40G(QSFP+)  BondMember  ====  fortyGigE 0/45                                 Master: mxl2link(UP)
swp2          40G(QSFP+)  BondMember  ====  swp2               cumulus-atlas-sw2.nipne.ro  Master: peerlink(UP)
swp20         40G(QSFP+)  BondMember  ====  fortyGigE 0/41                                 Master: mxl2link(UP)
swp21s0       10G(4x10G)  BondMember  ====  Eth1/1             c5k-atlas-workers           Master: c5klink(UP)
swp21s1       10G(4x10G)  BondMember  ====  Eth1/2             c5k-atlas-workers           Master: c5klink(UP)
swp21s2       10G(4x10G)  BondMember  ====  Eth1/3             c5k-atlas-workers           Master: c5klink(UP)
swp21s3       10G(4x10G)  BondMember  ====  Eth1/4             c5k-atlas-workers           Master: c5klink(UP)
swp23s0       10G(4x10G)  BondMember  ====  00:07:43:11:e8:c7                              Master: atlasgwlink(UP)
swp23s1       10G(4x10G)  BondMember  ====  00:07:43:11:e8:cf                              Master: atlasgwlink(UP)
swp23s2       10G(4x10G)  BondMember  ====  00:07:43:11:e5:2f                              Master: atlasgwlink(UP)
swp23s3       10G(4x10G)  BondMember  ====  00:07:43:11:e5:27                              Master: atlasgwlink(UP)
swp3          40G(QSFP+)  BondMember  ====  swp3               cumulus-atlas-sw2.nipne.ro  Master: peerlink(UP)
swp4          40G(QSFP+)  BondMember  ====  swp4               cumulus-atlas-sw2.nipne.ro  Master: peerlink(UP)
cumulus@cumulus-atlas-sw1$ netshow --version
Netshow Version:
netshow-core: 1.1.3
netshow-cumulus: 1.1.6
netshow-linux: 1.1.6

Cheers,
       Gabriel