Possible bug in NCLU regarding trunk configuration

  • 1
  • Problem
  • Updated 1 year ago
I don't know if this is a "bug" per se, but it sure seems like one.  So I'm playing around with nclu and creating trunks and vlans and all that and noticed that when I remove an interface as bridge-trunk, and commit the changes, a 'net show bridge vlan' still lists that interface as a trunk. Did this between two ports - swp40 first, then swp30.  The output of deleting swp30 as a trunk is included below:
cumulus@Switch_3:~$ net del interface swp30 bridge-trunkcumulus@Switch_3:~$ net commit
--- /etc/network/interfaces     2017-01-31 15:19:25.787592001 +0000
+++ /var/run/nclu/iface/interfaces.tmp  2017-01-31 15:20:13.731619975 +0000
@@ -14,15 +14,14 @@

 auto swp30
 iface swp30

 auto swp40
 iface swp40
     mtu 9216

 auto bridge
 iface bridge
-    bridge-ports swp30
     bridge-vids 20 40 70 98-101
     bridge-vlan-aware yes

 ##*** bond ports to uplink switches **

net add/del commands since the last 'net commit'

User     Timestamp                   Command
-------  --------------------------  ------------------------------------
cumulus  2017-01-31 15:20:10.746542  net del interface swp30 bridge-trunk

cumulus@Switch_3:~$ net show bridge-vlan
ERROR: Command not found

Use 'net help KEYWORD(s)' to list all options that use KEYWORD(s)
cumulus@Switch_3:~$ net show bridge vlan
port    vlan ids
swp30    1 PVID Egress Untagged

bridge  None
Photo of Troy MacDonald

Troy MacDonald

  • 720 Points 500 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Pete B

Pete B, Official Rep

  • 2,774 Points 2k badge 2x thumb
Hi Troy, if you're seeing this in Cumulus Linux, I recommend you file a ticket with our support team. Or are you noticing this in VX?