Supported Link modes - Unable to set Speed

  • 1
  • Question
  • Updated 1 year ago
I am unable to set speed of a switch. I could see that the supported modes of port is 10000

cumulus@cumulus:~$ sudo ethtool xxx
Settings for swp8s3:
        Supported ports: [ FIBRE ]
        Supported link modes:   10000baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Advertised link modes:  Not reported
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Speed: 10000Mb/s
        Duplex: Full
        Port: FIBRE
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: off
        Link detected: yes

When I try to execute the command

 ethtool -s swp8s2 speed 1000 duplex full

it throws error,
Cannot set new settings: Operation not supported
  not setting speed
  not setting duplex

Is it because its not in the "Supported link modes"?
Photo of Nivas


  • 256 Points 250 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Mike Brown

Mike Brown, Employee

  • 180 Points 100 badge 2x thumb
Hi Nivas.  Yes, that is correct. the supported speed interpreted for the module is 10,000 and you are trying to do 1,000.
It is possible to get 1G over a 4x10G breakout scenario, but it requires modules that support it and it may require a CL version change.
What is your use case and what module/cable do you have installed?  Also what switch hardware and CL version are you running?

It may be a good idea to open a support case to sort out the particulars of your scenario.