VX - doesn't launch in virtualbox verr_pdm_driver_not_found

  • 1
  • Problem
  • Updated 2 years ago
Hi there. I'm new to Cumulus and took the liberty of downloading the Virtualbox VX image to try it out. I double clicked on it to import but when I tried starting it, it wouldn't start. Virtualbox closed the session window and displayed the error message below.



I tried searching the KB and the community forum but wasn't able to find anything. Running VirtualBox 5.0.24 r108355 with the same version Extension Pack on Windows 7.

Any suggestions would be most appreciated.
Photo of David

David

  • 112 Points 100 badge 2x thumb
  • sad

Posted 2 years ago

  • 1
Photo of Nick Mitchell

Nick Mitchell, Employee

  • 544 Points 500 badge 2x thumb
Hi David. I wasn't seeing this issue, but I was also running an earlier version of VirtualBox. I upgraded to 5.0.24 and saw the same error after importing the VM, when trying to start it.

Still don't know the root cause of the error, though it appears to go away when I edit the settings and close without making any changes. Can you try that on your system?
Photo of Eric Pulvino

Eric Pulvino, Official Rep

  • 3,930 Points 3k badge 2x thumb
Which version of Vx are you using here -- 2.5.x or 3.x?

I just upgraded my Virtualbox install from 5.0.18 --> 5.0.24 and tried a fresh download of the 3.0 Virtualbox Vx from the website... no problems so far.

How are you adding the VM to virtualbox? Are you doubleclicking the OVA file or using the "import appliance" option from within the Virtualbox GUI?
Photo of David

David

  • 112 Points 100 badge 2x thumb
Thanks to both of you. Nick - your solution worked - I clicked on settings, closed, then restarted Virtualbox and boom, problem gone. Odd, but thankful it went away.
Photo of Jason Heller

Jason Heller, Employee

  • 232 Points 100 badge 2x thumb
Found this same issue with VX and through some additional digging figured out it's actually the Audio driver set in VX that causes the issue. When you open the settings in the GUI it automatically fixes the audio driver problem by setting the driver to "Null". I filed a ticket to resolve this in future VX builds for VirtualBox.

If you want to fix the problem before booting you can modify the .vbox configuration file and change this line:
<AudioAdapter controller="AC97" driver="ALSA" enabled="true"/>
to
<AudioAdapter controller="AC97" driver="Null" enabled="true"/>
(Edited)
Photo of David

David

  • 112 Points 100 badge 2x thumb
Thank you very much for the follow up. I will make the change.